Joomla! 2.5 - Extra Features! Easy Updates! Too many exclamation marks!

Joomla 2.5 Stable Released

Joomla! 2.5 - Extra Features! Easy Updates! Too many exclamation marks!As of January 24th 2012 Joomla 2.5 was made generally available, in line with Joomla’s six-month release cycle which  started with the delivery of Joomla 1.6 in January 2011 and Joomla 1.7 in July, 2011.

At first glance it seems very similar to the previous version, but “under the hood” there are a number of key enhancements and new features, including:

Automatic notification when a Joomla or extension update is available. This extends on the update functionality already present in previous versions. As a Joomla developer I find this particularly welcome.

A better natural language search engine to the Joomla core, faster and more versatile than the standard search, and offering better functionality such as auto-completion and stemming (for example if you type “running” in a search field you also see run).

Multi-database support, which should make Joomla more attractive to a corporate user-base and improve scalability. Joomla 2.5 offers support for Microsoft SQL Server, with Oracle support promised in the near future. Previous versions of Joomla supported MySQL exclusively. Again, from the perspective of a Joomla developer this is a particularly welcome feature in raising the profile of Joomla amongst prospective clients. Generation X already offer a choice of Linux or Windows-based hosting to our clients, and can now offer Joomla on either platform. However, as an advocate of Open Source software my default setup will remain MySQL-focused.

Joomla 2.5 demonstrates what a truly collaborative community-driven software project Joola is, having been developed with the feedback gathered from more than 2.5 million Joomla forum posts, 540,000 Joomla forum members and data from more than 8,800 Joomla extensions.

However, before widespread adoption can take place wider support for Joomla extensions such as Virtuemart and Community Builder will be needed for Joomla 2.5. I had been hoping to use Joomla 2.5 on a new eCommerce project today, but Virtuemart 2.0 does not yet support this latest version of Joomla, and while support is promised within the next fortnight it seems prudent to develop the site using the Joomla 1.7.4 version, and upgrade to Joomla 2.5 when Virtuemart support becomes available (and stable).

 

Leave a Reply

Your email address will not be published. Required fields are marked *